OpusClip - We're currently experiencing issues with the editor. You may not be able to crop your clips as expected. We're working on it and appreciate your patience! – Incident details

All systems operational

We're currently experiencing issues with the editor. You may not be able to crop your clips as expected. We're working on it and appreciate your patience!

Resolved
Major outage
Started 10 days agoLasted 37 minutes

Affected

Video Editing Service

Operational from 12:40 PM to 1:17 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.