OpusClip - We're currently experiencing issues with importing YouTube links. Please use local uploads, Google Drive, or other video links instead. We're working on it and appreciate your patience! – Incident details

All systems operational

We're currently experiencing issues with importing YouTube links. Please use local uploads, Google Drive, or other video links instead. We're working on it and appreciate your patience!

Resolved
Major outage
Started 3 days agoLasted about 1 hour

Affected

Video Import Service

Operational from 11:01 AM to 12:06 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.